てくてくあるく

WordPress の テーマ とか プラグイン に ついて 勉強しています

今まで 使ってた記述だと エラーが 表示されてたので 修正しました

まぁ コレは 僕の記述がよくなかった だけなんですけどね…

今まで書いてた コードが コレ

    function __construct() {
      $widget_option = array( 'description' => 'ディスクリプション' );
      parent::WP_Widget( false, $name = 'タイトル', $widget_option );
    }

んで 書きなおしたコードがコレ

    function __construct() {
      $widget_option = array( 'description' => 'ディスクリプション' );
      parent::__construct( false, $name = 'タイトル', $widget_option );
    }

これで エラーはなくなりましたとさ


そういえば エラーの種類は なんだったっけ??
Warning だったかな?? Notice だったかな??
止まってはいなかったから (多分)
Fatal では なかった気がするけど…

Related Article

Bootstrap v4.0.0-beta で テーマ を 更新しました!!

詳細へ »

FrontPage に 広告用 ウィジェットエリア を 表示させてみた

詳細へ »

2017/01/06 に Bootstrap 4 Alpha 6 が 来ていました

詳細へ »